Справка - Поиск - Участники - Войти - Регистрация
Полная версия: Linux
Частный клуб Алекса Экслера > Софт
Страницы: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20
Chief
20 января 2011, 23:01

ilya_ya написал: Рутовый пароль тоже не помнишь?

На последних не серверных дистрибах он залочен, открыт только sudo...
Марклар с Марклара
21 января 2011, 20:46


Не на всех. На Федоре, ASP, Мандриве/PCLinuxOS и AltLinux рутовый пароль точно задается в явном виде. В SuSE вроде тоже, но нет полной уверенности. В Ubuntu да, его нет.
cadaber
23 января 2011, 04:52
Конечно, можно пароль поменять, типо: зайти под root и passwd. В дистрах типа Ubuntu, я, к стыду своему не знаю как - я обычно в slackware.
ilya_ya
23 января 2011, 10:39

Chief написал:
На последних не серверных дистрибах он залочен, открыт только sudo...

Можно и разлочить. smile.gif

ilya_ya
23 января 2011, 10:41

cadaber написал: В дистрах типа Ubuntu, я, к стыду своему не знаю как -  я обычно в slackware.

Говорят, на русский язык Ubuntu переводится, как "не осилил поставить Slackware" или "не осилил поставить Gentoo". kos.gif
Chief
23 января 2011, 11:56

ilya_ya написал: Можно и разлочить.

Можно, но для этого надо

Chief написал: в консоль с рутовыми правами  или загрузись с ливсд

smile.gif
Марклар с Марклара
23 января 2011, 13:59

ilya_ya написал:

Скорее, "не осилил поставить Debian" smile.gif. Учитывая, какая там пакетная система. А Slackware кстати считается не совсем идеологически выдержанным дистрибутивом, потому как там инит BSD-шный, а не System 5. Кстати, хороший метод троллить слакваристов, напоминая им об этом прискорбном факте.
З.Ы. Сам слакварист с 10-летним стажем.
ilya_ya
23 января 2011, 23:35

Chief написал:
Можно, но для этого надо

Совсем не обязательно - если загрузчик GRUB - заходим в редактирование соответствующего пункта загрузки, добавляем в параметры ядра параметр single (в современных дистрибутивах этот режим, как правило, не залочен) и загрузившись в этом режиме получаем рутовый шелл без запроса пароля.
Это если пароль забыли. А если свой пароль помним, то это делается через sudo.
Нутый Чoк
24 января 2011, 00:52

ilya_ya написал:  "не осилил поставить Slackware" или "не осилил поставить Gentoo".

А для чего это осиливать?
Chief
24 января 2011, 02:04

ilya_ya написал: А если свой пароль помним, то это делается через sudo.

Ты изначальный вопрос читал? Пароля как раз и не помнят... А абстрактно обсуждать скучно...
ilya_ya
25 января 2011, 01:26

Chief написал:
Ты изначальный вопрос читал? Пароля как раз и не помнят... А абстрактно обсуждать скучно...

Скачал-таки с Яндекса дистрибутив Mandriva Linux 2010.0 и поставил на тестовой машинке.
Инсталлятор запросил отдельно рутовый пароль, отдельно юзерский, то есть отдельная рутовая учётка таки есть.
По дефолту используется загрузчик GRUB с графическим меню и в этом меню два пункта - нормальной загрузки и безопасного режима.
ART-venzel нужно сделать следующее:

1. В загрузочном меню, которое показывается на старте, выбрать безопасный режим и нажать enter. Система должна загрузиться в рутовую консоль без запроса каких-либо паролей.
2. В рутовой консоли набрать passwd и нажать Enter - появится запрос на ввод нового рутового пароля - задаём новый пароль два раза, после каждого жмя Enter.
3. После смены рутового пароля набираем команду reboot и жмём Enter - машина штатно перезагружается.
4. Грузимся в обычном режиме, вводим логин root с паролем, заданным двумя пунктами раньше.
Если загрузились в графическом режиме, запускаем какую-нибудь консоль или по Ctrl+Alt+F1 переключаемся в текстовую консоль и логинимся рутом там.
5. Из консоли с рутовыми правами набираем команду
passwd твой_логин
и жмём Enter. Задаём новый пароль уже для твоего логина аналогично рутовому.
6. Отлогиниваемся из рутовой учётки или перегружаемся командой reboot, залогиниваемся под своим именем с новым паролем и всё.
fedot
25 января 2011, 05:29

Марклар с Марклара написал: В SuSE вроде тоже, но нет полной уверенности. В Ubuntu да, его нет.

В Сусе тоже задается рутовый пароль, ставил 11.3 с пол-года назад (может чуть больше). Убунту вообще единственный кого я знаю, кто при инсталляции не спрашивает рут пароля.

Chief написал: Можно, но для этого надо

Теперь - да, а ранее, когда свой пароль еще был в голове, всего-навсего sudo bash, потом passwd smile.gif

ilya_ya написал: (в современных дистрибутивах этот режим, как правило, не залочен

Не уверен. У меня ощущение, что в single режиме меня запрашивали пароль. Дистрибутив не помню. Либо SuSe, либо gentoo smile.gif
форя
28 января 2011, 10:53
Вставлю свои 5 копеек. Загрузившись по single, далеко не всегда получаешь шелл без ввода рутового пароля. У меня пароль спрашивается всегда. Шелл без пароля получается по init=/bin/sh, но пока не перемонтируешь "/" (или где у вас там etc лежит) на запись - ничего не выйдет. Т.е. грузимся по init=/bin/sh (синтаксис загрузчиков может различаться), потом mount с опцией "-oremount, rw", потом редактируем /etc/shadow, сохраняем, делаем на всякий случай sync, опять перемонтируемся, но уже в read only с oпцией "-oremount, ro" и можно перегружать/выключать машину.
PG
28 января 2011, 16:04

форя написал: ...опять перемонтируемся, но уже в read only с oпцией "-oremount, ro" и можно перегружать/выключать машину.

Не понял, а вот этот этап зачем? Не проще перезагрузиться сразу после sync?
форя
28 января 2011, 21:55
Когда read only, то меньше шансов, что с FS что-то произойдёт, когда ты будешь вырубать машину. Команды reboot у тебя не будет, и telinit тебе тоже не сильно поможет.
PG
29 января 2011, 10:48
Забавно, не знал.
bilbo
31 января 2011, 16:06
В школе стоит ALT Линукс. Клавиатура сильно тормозит после загрузки системы. Когда вводится логин и пароль с клавы, она набирает текст идеально. Войдя в систему в любом месте где надо набирать текст клавишу приходится нажимать подольше (1-2 сек.) чтобы символ напечатался.
Пока такое на двух машинах. Клавы меняли - пофигу.
Куда копать?
Roman_V_M
1 февраля 2011, 14:06
Интересно, можно ли нормально поставить Убунту-сервер на флэшку? Нормально, т.е. не в режиме лайв-СД/флэш, а с возможностью установки доп. пакетов и сохранения настроек.
Про Universal USB Installer знаю, но он нормально ставит только десктопную версию. Для серверной просто создается установочная флэшка без возможности работы с самой флэшки.
bilbo
1 февраля 2011, 14:42

bilbo написал: Войдя в систему в любом месте где надо набирать текст клавишу приходится нажимать подольше (1-2 сек.)
чтобы символ напечатался.

Идею с залипанием после многократного нажатия shifta проверили - мимо.
Какие ещё будут идеи?
ilya_ya
1 февраля 2011, 22:40

Roman_V_M написал: Интересно, можно ли нормально поставить Убунту-сервер на флэшку?

А кто мешает попробовать? Только зачем это нужно? На сервере, в отличие от десктопной версии, автоконфигурялок нет, так что придётся на новом железе вручную менять настройки системы, чтобы, к примеру, сеть заработала.
Roman_V_M
2 февраля 2011, 02:46

ilya_ya написал: А кто мешает попробовать?

Это я протупил. Просто установщик показал несколько дисков скази (у меня 2 диска в основной системе), а я почему-то думал, что флэшка будет обозначена как-то по-другому. Когда выбрал детальную разбивку, оказалось, что один из этих скази и есть флэшка. В общем, вопросе решен.

ilya_ya написал: Только зачем это нужно? На сервере, в отличие от десктопной версии,
автоконфигурялок нет, так что придётся на новом железе вручную менять настройки системы, чтобы,
к примеру, сеть заработала.

Менять я ничего не собираюсь. Просто периодически посещает мысль соорудить НАС/торрентокачалку, вот и хочу систему поставить на флэшку, а данные держать на дисках, плюс сделать подобие резинового пула при помощи mhddfs.
Чокки
15 февраля 2011, 02:57
Произошла достаточно странная вещь. У меня Ubuntu 9.10 под VMWare (XP x64), оттуда я подключаюсь к суперкомпьютеру в другом городе (ssh, обмен ключиками). Откуда ни возьмись, всё содержимое моей папки .ssh исчезло. Создал новые ключи, отослал публичную половинку тамошнему одмину, всё снова заработало. Ничего не обновлялось, ничего не устанавливалось. Как? Почему?
форя
15 февраля 2011, 12:15

Чокки написал: Произошла достаточно странная вещь. [...] Откуда ни возьмись, всё содержимое моей папки .ssh исчезло. [...] Как? Почему?

Интересно, какой ответ ты надеешься получить, задавая вопрос, мол, положил книгу месяц назад на стол, а сегодня смотрю - нет книги на столе. Как? Почему?
А очень просто: или происходит чудо и книга .ssh/* исчезает по-волшебству, или кто-то взял, да и убрал/выкинул книгу .ssh/*. Сам понимаешь, что ни по первому случаю, ни по второму, тебе никто ничего конкретного, из-за отсутсвия информации, не скажет.
Чокки
15 февраля 2011, 20:17

форя написал:
Интересно, какой ответ ты надеешься получить, задавая вопрос, мол, положил книгу месяц назад на стол, а сегодня смотрю - нет книги на столе. Как? Почему?
А очень просто: или происходит чудо и книга .ssh/* исчезает по-волшебству, или кто-то взял, да и убрал/выкинул книгу .ssh/*. Сам понимаешь, что ни по первому случаю, ни по второму, тебе никто ничего конкретного, из-за отсутсвия информации, не скажет.

Я понимаю и даже поддерживаю твой наезд, но мне и правда абсолютно нечего к этому добавить.
shizsa
15 февраля 2011, 20:29

Чокки написал: но мне и правда абсолютно нечего к этому добавить.

Откат виртуальной машины не прокатит, как вариант? (т.е. не могло это быть причиной?)
Чокки
15 февраля 2011, 22:58

shizsa написал:
Откат виртуальной машины не прокатит, как вариант? (т.е. не могло это быть причиной?)

Руками я ничего не откатывал, все автоматические апдейты VM отключены, насколько вижу. Мож есть какая-то нечаянно набранная комбинация на клаве, которая удаляет все сертификаты? smile.gif
bilbo
17 февраля 2011, 14:25
Дано:
0. я - в Linux практически ноль.
1. школьный компьютерный класс из10 машин стоящих недалеко друг от друга. (т.е. локальной сети нет). ОС - ALT-Linux
2. Роутер DSL-2640U (4 LAN)
Надо: наладить выход в интернет всем машинам класса.
Вариант 1 (максимально дешёвый): докупаю свич, ставлю его между роутером и локалкой. Минус - нет гибкой настройки работы в интернете разных пользователей. Насколько она нужны буду ещё выяснять.
Вариант 2: притаскиваю с бухгалтерии списанный комп и мастерю на нем шлюз. Минус - пункт 0 - я даже не знаю с чего начать. (в смысле Linux реализации)

Вопрос: что посоветуете в случае второго варианта. Т.е. что можно использовать в качестве шлюза исходя из (пока) малограмотной поддержки и (к сожалению постоянно) ограниченного бюджета? И сколько это будет стоить?
форя
17 февраля 2011, 15:31
Если ты совсем не знаешь линукса, то тебе будет нереально настроить и поддерживать покомпьютерную раздачу интернета. Учитывая вариант "0", вариант "1" - твоё всё.
shizsa
17 февраля 2011, 16:31

bilbo написал: что посоветуете в случае второго варианта.

Вариант 2: запустить это в качестве школьного проекта по информатике. wink.gif
Chief
17 февраля 2011, 17:49

shizsa написал: Вариант 2: запустить это в качестве школьного проекта по информатике.

Скучно, продвинутый школьник это сделает за один урок... Если раздача инета не подразумевает собой раздачу банк-клиентам доступа в инет, внешнюю почту через mail-клиенты, etc...
Установка линукса занимает около получаса, доустановка сквида еще минут 10 (если с инета качать через YaST, apt-get, etc), чтение http://squid.opennet.ru/ в плане изучения построения конфигов (их еще и готовыми почти взять можно) при разных способах аутентификации - пока линукс ставится, в случае ncsa-auth - еще и по htpasswd простенький хелп можно почитать, чтоб проще пользователей заводить... Так что 45 минут на все - выше крыши... Ну можно еще поразвлекаться с апачем для установки SAMS, но это то уже не обязательно... kos.gif
bilbo
17 февраля 2011, 22:07
Спасибо всем за ссылки (будем почитать) и идею с обучением. Главное что б согласились платить - а чему учить - здесь на форуме и сочиним biggrin.gif.
Нутый Чoк
12 марта 2011, 21:35
В наличии: ноутбук — 1 шт., Windows 7 Pro — 1 шт., Ubuntu 10.10 — 1 шт., вайфай — 1 шт.
Под Вин7 скорость закачки с торрентов достигает 1 Мбит/с, обычно между 600 и 800 кбит/с. Под убунтой никогда не поднимается выше 150 кбит/с, а большую часть времени вообще около 100.
В чем может быть причина и как такое лечить?

Карта Intel® PRO/Wireless 3945ABG Network Connection.
Chief
12 марта 2011, 21:56

bilbo написал:  Главное что б согласились платить - а чему учить - здесь на форуме и сочиним

Сочиним, мне бы твои проблемы...smile.gif
Но мои в администрирование или даже на бсдпортал, я еще не решил...smile.gif
aik
12 марта 2011, 22:14

Нутый Чoк написал:
В чем может быть причина и как такое лечить?

Линукс маздай. biggrin.gif

А если серьезно, надо глянуть, может из-под линукса коннектится в скаком-нибудь сильно медленном режиме...
Chief
12 марта 2011, 22:19

aik написал: А если серьезно, надо глянуть, может из-под линукса коннектится в скаком-нибудь сильно медленном режиме...

Угу, ifconfig в студию...smile.gif
Roman_V_M
12 марта 2011, 22:20

Нутый Чoк написал: В чем может быть причина и как такое лечить?

Настройки торрент-клиента тоже не мешало бы проверить. Ты Трансмишин используешь, или другой клиент?
Нутый Чoк
12 марта 2011, 22:33

Chief написал:  ifconfig в студию...

CODE
wlan0     Link encap:Ethernet  HWaddr 00:19:d2:61:95:71  
         inet addr:192.168.1.3  Bcast:192.168.1.255  Mask:255.255.255.0
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:24335 errors:0 dropped:0 overruns:0 frame:0
         TX packets:37734 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:3609993 (3.6 MB)  TX bytes:35335309 (35.3 MB)


Roman_V_M написал: Ты Трансмишин используешь, или другой клиент?

Его или KTorrent. Еще пару каких-то пробовал, то же самое.

aik написал: Линукс маздай.

Я тоже про это стал подумывать biggrin.gif
aik
13 марта 2011, 00:17

Нутый Чoк написал:

Попробуйте с другой стороны подойти.
Проверьте скорость через speedtest.net - и из-под линукса, и из-под windows.
Посмотрите в веб-интерфейсе точки доступа, может там написано, какой именно клиент подключился (a/b/g/n...)
aik
13 марта 2011, 11:59
Устраняем проблемы в Ubuntu 10.10 - там есть про медленный вайфай в 10.10. Гляньте, может ваш случай.
Марклар с Марклара
13 марта 2011, 15:48

Нутый Чoк написал:

Проблема в драйверах для Linux. Вопросы в Intel. Довольно распространенная ситуация.
Нутый Чoк
13 марта 2011, 17:03

aik написал: Проверьте скорость через speedtest.net - и из-под линукса, и из-под windows.

Проверял как раз недавно smile.gif Было 1 Мбит/с и около 4.

aik написал: Посмотрите в веб-интерфейсе точки доступа,

Туда у меня доступа нет, увы.

aik написал: Устраняем проблемы в Ubuntu 10.10 -

Сделал как там написано, понаблюдаю.

Марклар с Марклара написал: Довольно распространенная ситуация.

Фиговая ситуация-то mad.gif
Нутый Чoк
18 марта 2011, 18:03

Нутый Чoк написал: Сделал как там написано, понаблюдаю.

Чуть-чуть побыстрее стало, хотя до 600 Кбит/с еще как пятидюймовой дискете до двд-рв.
Нутый Чoк
31 марта 2011, 16:02
Не знаю, что произошло, но сегодня наблюдаю скорость до 700 Кбит/с. Я ничего не делал, я не виноват biggrin.gif
engelson
11 апреля 2011, 20:50
Чувствую себя полным идиотом.
Установил на ноут ASUS M6000 Debian Squeeze. (До этого там Lenny долго жил не тужил).
При попытках смотреть видео в браузере (любом: Iceweasel, Opera, Chrome) всё нормльно, пока я не пытаюсь перейти в полноэкранный режим отображения. Браузер тут же схлопывается без предупреждения. Я в полном замешательстве.
В какую сторону копать?

ps.gif Chrome показывает грустный пазлик и надпись: " Произошел сбой следующего подключаемого модуля: Shockwave Flash"
Нутый Чoк
11 апреля 2011, 21:07
Копать в сторону флэша — какая версия стоит?
engelson
11 апреля 2011, 21:10
Shockwave Flash 10.2 r152

Adobe Flash переставлял неоднократно - не помогло. frown.gif Свеженький.

Кодеки?
Нутый Чoк
12 апреля 2011, 18:14
Да кодеки тут не виноваты, это все кривой флэш для линукса. Сейчас уже 10.2.153 есть, попробуй его. Система случайно не 64-битная?
У меня на полноэкранном режиме вообще иногда все зависало, так что я им и не пользуюсь.
Serg Inc.
12 апреля 2011, 18:23

Нутый Чoк написал: Система случайно не 64-битная?  У меня на полноэкранном режиме вообще иногда все зависало, так что я им и не пользуюсь.

В 64-битном флеше недавно была проблема, связанная с изменения где-то в stdlib (memcpy заоптимизировали). На сайте fedora, кажется, в багтрекере была длиннющая ругань с участием Торвальдса.

Может, оно?
engelson
13 апреля 2011, 14:47

Нутый Чoк написал:  Система случайно не 64-битная?

Нет, обычная 32 битная. Ноут старенький. Адоб флеш... Ну попробую ещё раз обновить, но что-то мне подсказывает, что дело не в нём.
engelson
14 мая 2011, 01:33
Итак, отчитываюсь о том, что узнал.
AdobeFlash посылает меня к производителю видеокарты за драйвером. Карта ATI mobilty Radeon 9700. Больше, грит помочь ничем не могу. К вендору-к вендору.
На сайте ATI (точнее, уже AMD) пишут, что есть чудесные дрова для Висты и Вин7.
Linux? Есть и Linux. Lenny. Естественно мне с моим Squeeze оно не подходит. Ибо обновился.
Вот всё.
Вряд ли ATI будет выпускать драйвер для карты, которая давно снята с производства.
Так что полноэкранного видео мне на этом ноуте не видать.
На нетбуке MSI Wind U90 все без проблем работает. Даже при подключении внешнего монитора. Старость железа - не радость. Это я на Sqeeze ещё тридэшных игр не пробовал. Да и не буду теперь. На Lenny всё работало. Только поддержка Lenny в следующем году по слухам прекратится.
Дальше >>
Эта версия форума - с пониженной функциональностью. Для просмотра полной версии со всеми функциями, форматированием, картинками и т. п. нажмите сюда.
Invision Power Board © 2001-2017 Invision Power Services, Inc.
модификация - Яро & Серёга
Хостинг от «Зенон»Сервера компании «ETegro»