Справка - Поиск - Участники - Войти - Регистрация
Полная версия: DNS не хочет работать после подключения
Частный клуб Алекса Экслера > Наши сети притащили
Гриф
30 сентября 2015, 19:07
Глупая ситуация, даже неудобно вас дёргать - но я уже голову сломал.

Домашняя Wifi. Простейший маршрутиризатор Dlink-665, который воткнут в кабельный модем. Конфигурация существует уже давно с небольшими изменениями (модем менялся пару раз). Соединяюсь с ноутбука (Win7, встроенный WiFi) к маршрутиризатору, получаю Интернет, работаю. Закрываю крышку и ноут уходит в сон.

Открываю крышку, система встаёт, автоматически соединяется, показывает "Internet access". Скайп - соединён. WWW - нет (ни одна страница не открывается). Делаю ping на yahoo.com - не проходит. A если по IP? - Нет проблем. Ага, значит имена доменов не разрешаются. Делаю "ipconfig /flushdns" - не помогает. Отсоединяюсь и обратно (disconnect/connect) - не помогает. Остальные компьютеры (десктоп и АйПад) работают как ни в чём не бывало. ipconfig показывает DNS Server = 75.75.75.0 (или 76, точно не помню сейчас).

У жены есть парочка своих отдельных точек доступа (access point), которые идут в тот же маршрутиризатор. Жена даёт мне доступ, соединяюсь - нет Интернета, в том же виде, как и раньше (напрямую в маршрутиризатор). Вижу соседскую открытую сеть, подсоединяюсь - всё работает без проблем. Возвращаюсь обратно - нет WWW. Единственная пока мне доступная процедура: с ноута из Firefox иду в админку маршрутиризатора и перезагружаю устройство. Все опять довольны. Если я перед закрыванием крышки пойду в "Available networks" и вручную "disconnect" от моей домашней сетки - то после выхода ноута из сна могу сделать "connect", и всё будет работать ОК. С этим же самым маршрутиризатором несколько лет не было этой проблемы - и вдруг такая фигня. Firmware - самое свежее. Система (Win) - со всеми обновлениями.

Есть какие-нибудь суждения или советы? Заранее спасибо.
Chief
30 сентября 2015, 21:04

Гриф написал: 75.75.75.0

Такого адреса не существует.
Но если честно - очень сумбурно и при этом плохо понятно...
ipconfig /all ДО и ПОСЛЕ подключения. Далее результаты hijackthis и

Гриф написал: Отсоединяюсь и обратно (disconnect/connect)

Отключаешь в винде устройство или просто отключаешь сеть?
Если второе, то попробуй отключить/включить именно утсройство. Последний месяц я стал с этим часто сталкиваться...
Гриф
30 сентября 2015, 22:43

Chief написал:
Такого адреса не существует.

Я знаю. Потому и написал.


Но если честно - очень сумбурно и при этом плохо понятно...

Я старался, но видимо недостаточно. mad.gif
Chief
1 октября 2015, 11:59

Гриф написал: Я старался, но видимо недостаточно.

Бывает.smile.gif
Но все же мой вопрос про отключение сети или устройства - важен. Я действительно в последнее время (месяц, может чуть больше) стал натыкаться на хреновое поведение сети на win, при этом помогает именно отключение сетевухи и ее последующее включение (в устройствах я имею ввиду, не физически выдираюsmile.gif). Связанно это с каким то обновлением или есть другая причина - пока статистики не набрал, но факт остается...
Гриф
2 октября 2015, 00:50

Chief написал:
Но все же мой вопрос про отключение сети или устройства - важен.

В notifications area через иконку Wifi выбираю мою домашнюю сеть (среди других доступных), и правым щелчком делаю "disconnect". То есть самое поверхностное "отключение", не меняя ничего в интерфейсе, или того хуже - устройстве.
Woozy
6 октября 2015, 01:15
Барахлит "интересно". Смутно вспоминаю похожую историю, когда помог reset собственно устройства. Для твоего устройства reset. Или производитель коробочки говорит. В начальные установки его сбросить, заодно потрёт кучку неправильных таблиц, там тоже софт, он тоже глючит. Большинство модемов/раутеров можно сбрасывать и через браузер.
Гриф
6 октября 2015, 05:27

Woozy написал: Для твоего устройства reset.

Да, звучит разумно: если не помогает soft reset, надо ему вкатить hard. Попробую откатить на фабричные установки - и уже оттуда плясать. Посмотрим.
Гриф
7 октября 2015, 20:32

Chief написал: Такого адреса не существует.

Оказывается, мой провайдер (Comcast) делает это нарочно: они перехватывают запросы к несуществующим адресам (75.75.75.75 и 75.75.76.76), выделяют DNS-запросы, и перенаправляют их в нужные сервера в зависимости от моего географического положения. It's not a bug, it's a feature smile.gif
Эта версия форума - с пониженной функциональностью. Для просмотра полной версии со всеми функциями, форматированием, картинками и т. п. нажмите сюда.
Invision Power Board © 2001-2017 Invision Power Services, Inc.
модификация - Яро & Серёга
Хостинг от «Зенон»Сервера компании «ETegro»