Справка - Поиск - Участники - Войти - Регистрация
Полная версия: Проблемы клиентом
Частный клуб Алекса Экслера > The ECS project
Страницы: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24
regex
31 мая 2012, 08:46

Developer написал: К сожалению, быстро починить не получается. Рабочее место у меня поломалось.

А причем здесь ты? Проблема в серверных скриптах - у меня версия клиента старая, новости сейчас не обновляются. Надо разбираться.
regex
31 мая 2012, 10:03
Нет, все-таки проблема в клиенте: обновляются новости. Но обновляются 15 минутными пачками от времени последнего обновления (у меня с 11 мая). Как его заставить обновить все (кроме как поправить ини-файл), я не знаю.

Я пока поставил выкачивание новостей за сутки (но там есть ограничение в 500 постов) - посмотрим, как догонят.
Developer
31 мая 2012, 11:52

regex написал: А причем здесь ты?

Проще всего посмотреть под отладкой, почему не работает.

Вчера обнаружил в коде парсера ответа новостей ожидание тэга <p> между </threads>и <bluetime>. В реальном ответе этого тэга нет. Из-за его остутствия само время последнего обновления может не сохраняться и тогда клиент снова будет посылать запрос без параметра bluetime

Как себя этом случае поведёт скрипт?
regex
31 мая 2012, 12:22
Выдаст за последние 15 минут (а раньше в этом случае он пытался вытащить посты за все время, что и привело к полеганию сервера перед майскими праздниками.

<p> добавил. Стало обновляться?
Developer
31 мая 2012, 12:43

regex написал: Стало обновляться?

Похоже, что - нет. frown.gif

Так что от пристального исследование под микроскопом не отвертеться.
Rishelie
31 мая 2012, 16:46
Что-то непонятное творится.
Новости выкидывают обновления, но почему то на темы, где ничего не происходит.
А в темах, где идет разговор - в новостях тишина.
Это в частности про МиЖ.

А есть форумы, где обновление тем проходит успешно.
Очистка кеша, ctrl+Ф5, ctrl+del... не помогает.
Типа клиент работает а толку никакого.
Sheva
31 мая 2012, 23:08

Developer написал: К сожалению, быстро починить не получается.

Ничего, хоть читать и писать можно, и то хлеб! smile.gif Дочините, как будет время. Только этот не выключайте. pray.gif
Drumm
1 июня 2012, 06:50

Rishelie написал: Типа клиент работает а толку никакого.

Заелись вы ИМХО... Толку им никакого!

SolaFide написала: Ничего, хоть читать и писать можно, и то хлеб!  Дочините, как будет время. Только этот не выключайте. 

ДА!
regex
1 июня 2012, 09:55
Новая версия клиента. Новости должны обновляться.
regex
1 июня 2012, 09:56

Rishelie написал: Что-то непонятное творится.
Новости выкидывают обновления, но почему то на темы, где ничего не происходит.
А в темах, где идет разговор - в новостях тишина.
Это в частности про МиЖ.

Спасибо, добрый человек. biggrin.gif ты открыл нам глаза 3d.gif
votani
1 июня 2012, 10:05

regex написал: Новая версия клиента. Новости должны обновляться.

Спасибо большое, всё обновляется.
Sheva
1 июня 2012, 11:40

regex написал: Новая версия клиента. Новости должны обновляться.

Целиком надо ставить, или экзешника хватит?
regex
1 июня 2012, 11:43
Вроде экзешника хватает.
Sheva
1 июня 2012, 11:51

regex написал: Вроде экзешника хватает

Ага, но ini я все равно добавила, ну там всякие избранные и все такое. Вроде заобновлялось... Спасибо!!!
Sheva
1 июня 2012, 11:54
Через минуту опять выскочило окно:
LamoNosov
1 июня 2012, 11:59
А у меня "Ошибка выполнения запроса на авторизацию. Код 0". Хотя логин и пароль ввожу 146% правильный.
regex
1 июня 2012, 12:11
А в вебе, как я понимаю, никаких проблем. Очень странно, поскольку парольная авторизация через обычные скрипты идет.

Про код ничего сказать в данный момент не могу - ждём версии, выдающей оригинальные ошибки, пришедшие из серверных скриптов.
LamoNosov
1 июня 2012, 12:51

regex написал: А в вебе, как я понимаю, никаких проблем. Очень странно, поскольку парольная авторизация через обычные скрипты идет.

В вебе все ок. Чуть подробнее опишу симптомы. Дома со старым клиентом вчера было все ок. Во всяком случае подключался, читал и отправлял сообщения. На работе вчера обновил клиента не глядя (в смысле, не проверяя, работает ли старый клиент) версией от 30 мая, а сегодня свежей. Заменил все 3 файла теми, что были в архивах. И вот такая ошибка была и вчера и теперь.
Developer
1 июня 2012, 12:52

SolaFide написала: Через минуту опять выскочило окно:

Это у тебя с Клиентом что-то личное. frown.gif Ошибку он показывает напрямую к Клиенту не относящуюся. Даже и не знаю, что посоветовать. confused.gif
Developer
1 июня 2012, 12:53

LamoNosov написал: А у меня "Ошибка выполнения запроса на авторизацию. Код 0".

Интернет Эксплорер не в оффлайн режиме находится?
Rishelie
1 июня 2012, 12:56

regex написал: Спасибо, добрый человек.

coquet.gif
Вроде вылетело, как нажал на ссылку с посте. Клиент при этом продолжил работать:

А повторно попытка пройти по ссылке - все нормально.
Rishelie
1 июня 2012, 12:59
С новой версией все вроде заработало. Ну вот кроме этой вылетевшей ошибки, пока других бяк не замечаю.
LamoNosov
1 июня 2012, 13:09

Developer написал:
Интернет Эксплорер не в оффлайн режиме находится?

Поглядел сейчас - нет, всё в порядке. Даже сделал его дефолтным браузером - не помогло. Видать, я кривовато патч накатил. Есть ли где полная версия клиента?
Developer
1 июня 2012, 13:24

LamoNosov написал: Видать, я кривовато
патч накатил.

Это - вряд ли. Никаких преобразований при обновлении не выполняется. Просто старый исполняемый файл переписывается новым. Он или работает или нет. Значит, дело не в этом.
votani
1 июня 2012, 13:25

LamoNosov написал: Есть
ли где полная версия клиента?

Тут.
LamoNosov
1 июня 2012, 13:43
Всё, отбой! У меня эксплорер в экспериментальных целях был настроен для работы через прокси, причем нифига не работал, и я про это забыл. Работу через прокси отключил - клиент коннектится, пишу из-под него.
Developer
1 июня 2012, 16:27

LamoNosov написал: У меня эксплорер в экспериментальных целях был настроен для работы через прокси, причем нифига не работал, и я про это забыл. Работу через прокси отключил - клиент коннектится, пишу из-под него.

Ну и славненько. 2jump.gif
Sheva
2 июня 2012, 00:20

Developer написал: Это у тебя с Клиентом что-то личное

Прикольно. smile.gif Если надумаешь что, то напиши. smile.gif
regex
2 июня 2012, 10:43

Developer написал: Это у тебя с Клиентом что-то личное. frown.gif

У меня, кстати, тоже при тестирование такое окно регулярно выскакивало.
Чеширка
2 июня 2012, 14:34
Работает! smile.gif
Только смайлики не ставит. wink.gif
Developer
3 июня 2012, 00:47

Чеширка написала: Только смайлики не ставит.

Ты, видимо, с нуля поставила только Ехешник? Чтобы были смайлики нужно полную версию скачать, распаковать, а потом скачать Ехешник и записать поверх полной версии.
Чеширка
3 июня 2012, 07:09

Developer написал: Чтобы были смайлики нужно полную версию скачать, распаковать, а потом скачать Ехешник и
записать поверх полной версии.

Новую полную версию? У меня старая-то есть.
Developer
4 июня 2012, 11:34

Чеширка написала: Новую полную версию? У меня старая-то есть.

Не обязательно новую. Старая тоже пойдёт. smile.gif Главное чтобы сами смайлики и файлик с их списком были на местах.
Чеширка
4 июня 2012, 16:52

Developer написал: Не обязательно новую. Старая тоже пойдёт

Хм, скопировала новый exe в старую папку, запустила клиент, а он мне сообщил - ниче не знаю, техничкой роблю сервер занят....
С новой папки все ок.
Sheva
4 июня 2012, 20:52
Приваты не получаю, даже если принудительно синхронизировать.
LamoNosov
5 июня 2012, 09:40
Приверно в 9-30 перестал работать клиент. Снова какие-то работы?
regex
5 июня 2012, 11:04
Может опять эксплорер виноват?
LamoNosov
5 июня 2012, 15:30
Да ёшкин кот! Всё время забываю про эту особенность клиента, что ему нужны настройки ИЕ для работы.
Всё. Под свои экспериментальные цели зарядил другой браузер.
Спасибо за подсказку!
NatRein
7 июня 2012, 22:23
Тест, пардон
NatRein
7 июня 2012, 22:32
regex & Developer
adore.gif обоих!! pray.gif
smile.gif

(клиент 2.35) 3d.gif
Anton
7 июня 2012, 23:08
Ссылка в спойлере. frown.gif
regex
7 июня 2012, 23:55
Это же клиент виноват, как я понимаю?
Vladimir_Y
8 июня 2012, 00:40

Anton написал: Ссылка в спойлере.

Кстати, если в спойлере ссылкой даётся картинка, то она кладётся в корень системного диска. WinXP.

Пример здесь.
Rishelie
8 июня 2012, 11:52
Есть вопрос. Наверно тут правильно будет.
В новостях постоянно вылетают темы, где нет новых сообщений.
Как с этим бороться?
Версия новая.
Anton
10 июня 2012, 20:11

regex написал: Это же клиент виноват, как я понимаю?

Ага.
Mistral
12 августа 2012, 22:39
Понимаю, что вряд ли кто-то на расстоянии сможет мне помочь, но вдруг.

Клиент перестал работать в связи с теми майскими сложностями, но когда у всех все заработало, у меня - нет frown.gif Проблема именно с домашним компом, на работе все фурычит. Вхожу в систему нормально, он меня узнает, список форумов открывает. А вот тему - уже нет. (Хотя, что странно, бывают и чудеса - несколько раз обновил список тем подфорума. Но так же не бывает, правда? Это мистика, так что оставим в стороне.)

Система - XP, Эксплорер не в автономе. Что еще изменилось: у меня браузер по умолчанию - Мозилла, и до катастрофы, если открывала из клиента в браузере тему или профиль, он использовал Мозиллу, теперь же использует Эксплорер (открывает без проблем).

Я уже и службы отключенные пыталась включать - не помогает frown.gif Может, у кого-нибудь есть догадки, чего ему не хватает, а? В браузере читать форум - это же просто мучение!
Sheva
13 августа 2012, 22:35
А у меня опять не работает. Что-то случилось?
Sheva
13 августа 2012, 22:43
Я пароль меняла. В клиенте тоже поменяла, потом заново перезашла, заново ключ ввела (старый сохраненный), а все равно вот что:


Sheva
13 августа 2012, 22:45
.Раз-раз.
Sheva
13 августа 2012, 22:45
О, ключ изменился после смены пароля. Буду знать!
Извините. shuffle.gif
Дальше >>
Эта версия форума - с пониженной функциональностью. Для просмотра полной версии со всеми функциями, форматированием, картинками и т. п. нажмите сюда.
Invision Power Board © 2001-2017 Invision Power Services, Inc.
модификация - Яро & Серёга
Хостинг от «Зенон»Сервера компании «ETegro»